IdeaStatiCa.ConnectionApi.Model.ConnectionSetup
ConnectionSetup
Properties
Name | Type | Description | Notes |
---|---|---|---|
SteelSetup | Object | ISteelSetup | [optional] |
ConcreteSetup | ConcreteSetup | [optional] | |
StopAtLimitStrain | bool | Stop analysis when the limit strain is reached. | [optional] |
WeldEvaluationData | WeldEvaluation | [optional] | |
CheckDetailing | bool | Perform check of bolt positions | [optional] |
ApplyConeBreakoutCheck | ConeBreakoutCheckType | [optional] | |
PretensionForceFpc | double | Pretension force fpc = k * fub * As | [optional] |
GammaInst | double | Partial safety factor of instalation safety | [optional] |
GammaC | double | Partial safety factor of concrete | [optional] |
GammaM3 | double | Preloaded bolts safety factor | [optional] |
AnchorLengthForStiffness | int | Length of anchor to define the anchor stiffness in analysis model, as a multiple of anchor diameter (E A /n * [d]) | [optional] |
JointBetaFactor | double | Joint coefficient βj - Used for Fjd calculation | [optional] |
EffectiveAreaStressCoeff | double | Effective area is taken from intersection of stress area and area of joined items according to EN1993-1-8 art. 6.2.5 | [optional] |
EffectiveAreaStressCoeffAISC | double | Effective area stress coefficient - Concrete loaded area: Stress cut-off is set for AISC | [optional] |
FrictionCoefficient | double | Coefficient of friction between base plate and concrete block | [optional] |
LimitPlasticStrain | double | Limit of plastic strain used in 2D plate element check | [optional] |
LimitDeformation | double | Limit deformation on closed sections | [optional] |
LimitDeformationCheck | bool | Limit deformation on closed sections check or not | [optional] |
AnalysisGNL | bool | Analysis with GNL | [optional] |
AnalysisAllGNL | bool | Analysis with All GNL | [optional] |
WarnPlasticStrain | double | Warning plastic strain | [optional] |
WarnCheckLevel | double | Warning check level | [optional] |
OptimalCheckLevel | double | Optimal check level | [optional] |
DistanceBetweenBolts | double | Limit distance between bolts as a multiple of bolt diameter | [optional] |
DistanceDiameterBetweenBP | double | Anchor pitch | [optional] |
DistanceBetweenBoltsEdge | double | Limit distance between bolt and plate edge as a multiple of bolt diameter | [optional] |
BearingAngle | double | Load distribution angle of concrete block in calculation of factor Kj | [optional] |
DecreasingFtrd | double | Decreasing Ftrd of anchors. Worse quality influence | [optional] |
BracedSystem | bool | Consider the frame system as braced for stiffness calculation. Braced system reduces horizontal displacements. | [optional] |
BearingCheck | bool | Apply bearing check including αb | [optional] |
ApplyBetapInfluence | bool | Apply βp influence in bolt shear resistance. ΕΝ 1993-1-8 chapter 3.6.1 (12) | [optional] |
MemberLengthRatio | double | A multiple of cross-section height to determine the default length of member | [optional] |
DivisionOfSurfaceOfCHS | int | Number of straight lines to substitute circle of circular tube in analysis model | [optional] |
DivisionOfArcsOfRHS | int | Number of straight lines to substitute corner arc of rectangular tubes in analysis model | [optional] |
NumElement | int | Ratio of length of decisive plate edge and Elements on edge count determines the average size of mesh element | [optional] |
NumberIterations | int | More iterations helps to find better solutions in contact elements but increases calculation time | [optional] |
Mdiv | int | Number of iteration steps to evaluate analysis divergence | [optional] |
MinSize | double | Minimal size of generated finite mesh element | [optional] |
MaxSize | double | Maximal size of generated finite mesh element | [optional] |
NumElementRhs | int | Number of mesh elements in RHS height | [optional] |
NumElementPlate | int | Number of mesh elements on plates | [optional] |
RigidBP | bool | True if rigid base plate is considered | [optional] |
AlphaCC | double | Long-term effect on fcd | [optional] |
CrackedConcrete | bool | True if cracked concrete is considered | [optional] |
DevelopedFillers | bool | True if developed fillers is considered | [optional] |
DeformationBoltHole | bool | True if bolt hole deformation is considered | [optional] |
ExtensionLengthRationOpenSections | double | ExtensionLengthRationOpenSections | [optional] |
ExtensionLengthRationCloseSections | double | ExtensionLengthRationCloseSections | [optional] |
FactorPreloadBolt | double | FactorPreloadBolt | [optional] |
BaseMetalCapacity | bool | BaseMetalCapacity | [optional] |
ApplyBearingCheck | bool | ApplyBearingCheck | [optional] |
FrictionCoefficientPbolt | double | Friction factor of slip-resistant joint | [optional] |
CrtCompCheckIS | CrtCompCheckIS | [optional] | |
BoltMaxGripLengthCoeff | double | Max value of bolt grip | [optional] |
FatigueSectionOffset | double | Fatigue section Offset = FatigueSectionOffset x Legsize | [optional] |
CondensedElementLengthFactor | double | Condensed element length factor (CEF). Condensed beam legth = maxCssSize * CEF | [optional] |
GammaMu | double | Partial safety factor for Horizontal tying | [optional] |
HssLimitPlasticStrain | double | Limit plastic strain for high strength steel | [optional] |