Table of Contents

Creating the Connection Rest API Client by IDEA StatiCa project templates

Since the IDEA StatiCa v24 BIM links projects can be created by project dotnet templates. Templates help users to create a IDEA StatiCa BIM link projects. It requires to install IdeaStatiCa.Dotnet.Templates. Open CMD terminal (or Powershell) and run :

dotnet new install IdeaStatiCa.Dotnet.Templates

To create a new BIM Fea plugin do following :

  1. Open CMD terminal (or Powershell) and create a directory for your project. Make sure template is intalled by running the command
dotnet new list

If templates are correctly this template should be in the list

IDEA StatiCa Connection Rest API Client Console  conapiconsole               [C#]        ideastatica/connection/api
  1. create a new solution in the project directory (in this case MyConApiClientApp.sln) for .NET 8.0
dotnet new conapiconsole -n MyConApiClientApp -F net8.0

for .NET Framework 4.8

dotnet new conapiconsole -n MyConApiClientApp -F net48
  1. Open it in Visual studio or build and run it by dotnet CLI
dotnet restore .\MyConApiClientApp.sln
dotnet build .\MyConApiClientApp.sln -c Release
MyFeaBIMApp\bin\Release\net8.0\MyConApiClientApp.exe

Creating BIM Link in Visual Studio

To create the console client application for IdeaStatiCa.ConnectionRestApi.dll select the template IDEA StatiCa Connection Rest API Client Console. Similar to creating the BIM API FEA link :

VS Wizard

Project name

Framework definition

fea-running-example