Table of Contents

ConcreteBlockData

Provides data of the single concrete block

Properties

Name Type Description Notes
id int Plate unique ID [optional]
name str Name of the concrete block [optional]
depth float Depth of the concrete block [optional]
material str Name of the material [optional]
center Point3D [optional]
outline_points List[Point2D] Outline points [optional]
origin Point3D [optional]
axis_x Vector3D [optional]
axis_y Vector3D [optional]
axis_z Vector3D [optional]
region str Geometry of the concrete block in svg format [optional]
original_model_id str Get or set the identification in the original model In the case of the imported connection from another application [optional]

Example

from ideastatica_connection_api.models.concrete_block_data import ConcreteBlockData

# TODO update the JSON string below
json = "{}"
# create an instance of ConcreteBlockData from a JSON string
concrete_block_data_instance = ConcreteBlockData.from_json(json)
# print the JSON string representation of the object
print(ConcreteBlockData.to_json())

# convert the object into a dict
concrete_block_data_dict = concrete_block_data_instance.to_dict()
# create an instance of ConcreteBlockData from a dict
concrete_block_data_from_dict = ConcreteBlockData.from_dict(concrete_block_data_dict)

[Back to Model list] [Back to API list] [Back to README]