PinGrid
Data of the pin grid
Properties
Name | Type | Description | Notes |
---|---|---|---|
is_replaceable | bool | Replaceable pin | [optional] |
pin | ReferenceElement | [optional] | |
origin | Point3D | [optional] | |
axis_x | Vector3D | [optional] | |
axis_y | Vector3D | [optional] | |
axis_z | Vector3D | [optional] | |
positions | List[Point3D] | Positions of holes in the local coordinate system of the grid | [optional] |
connected_parts | List[ReferenceElement] | List of the connected parts | [optional] |
name | str | Name | [optional] |
length | float | Length | [optional] |
id | int | Element Id | [optional] |
Example
from ideastatica_connection_api.models.pin_grid import PinGrid
# TODO update the JSON string below
json = "{}"
# create an instance of PinGrid from a JSON string
pin_grid_instance = PinGrid.from_json(json)
# print the JSON string representation of the object
print(PinGrid.to_json())
# convert the object into a dict
pin_grid_dict = pin_grid_instance.to_dict()
# create an instance of PinGrid from a dict
pin_grid_from_dict = PinGrid.from_dict(pin_grid_dict)