Class IdeaCrossSectionByParameters
- Namespace
- IdeaStatiCa.BimApiLink.BimApi
- Assembly
- IdeaStatiCa.BimApiLink.dll
public class IdeaCrossSectionByParameters : AbstractIdeaObject<IIdeaCrossSectionByParameters>, IEquatable<AbstractIdeaObject<IIdeaCrossSectionByParameters>>, IIdeaCrossSectionByParameters, IIdeaCrossSection, IIdeaObject
Inheritance
Implements
-
IIdeaCrossSectionByParametersIIdeaCrossSectionIIdeaObject
Inherited Members
Constructors
IdeaCrossSectionByParameters(Identifier<IIdeaCrossSectionByParameters>)
public IdeaCrossSectionByParameters(Identifier<IIdeaCrossSectionByParameters> identifer)
Parameters
identifer
Identifier<IIdeaCrossSectionByParameters>
IdeaCrossSectionByParameters(int)
public IdeaCrossSectionByParameters(int id)
Parameters
id
int
IdeaCrossSectionByParameters(string)
public IdeaCrossSectionByParameters(string id)
Parameters
id
string
Properties
IsInPrincipal
Specifies that the cross-section is in its principal axis.
public virtual bool IsInPrincipal { get; set; }
Property Value
Material
Material of the cross-section.
public virtual IIdeaMaterial Material { get; set; }
Property Value
- IIdeaMaterial
Parameters
Parameters of the cross-section. Parameters depend of the type of the cross-section. See CrossSectionFactory for more information about parameters.
public virtual HashSet<Parameter> Parameters { get; set; }
Property Value
- HashSet<Parameter>
Rotation
Rotation of the cross-section.
public virtual double Rotation { get; set; }
Property Value
Type
Type of the cross-section.
public virtual CrossSectionType Type { get; set; }
Property Value
- CrossSectionType