Table of Contents

Interface IGrpcService

Namespace
IdeaStatiCa.Plugin.Grpc
Assembly
IdeaStatiCa.Plugin.dll
public interface IGrpcService : IGrpcSender

Implements

Properties

IsConnected

bool IsConnected { get; }

Property Value

bool

Methods

ConnectAsync(IAsyncStreamReader<GrpcMessage>, IServerStreamWriter<GrpcMessage>, ServerCallContext)

Task ConnectAsync(IAsyncStreamReader<GrpcMessage> requestStream, IServerStreamWriter<GrpcMessage> responseStream, ServerCallContext context)

Parameters

requestStream IAsyncStreamReader<GrpcMessage>
responseStream IServerStreamWriter<GrpcMessage>
context ServerCallContext

Returns

Task

RegisterHandler(string, IGrpcMessageHandler)

void RegisterHandler(string handlerId, IGrpcMessageHandler handler)

Parameters

handlerId string
handler IGrpcMessageHandler