Table of Contents

Namespace IdeaStatiCa.Plugin.Grpc

Namespaces

IdeaStatiCa.Plugin.Grpc.Reflection
IdeaStatiCa.Plugin.Grpc.Services

Classes

BlobStorageGrpc
ContentData
ContentRequest
ExistResponse
GetEntriesRequest
GetEntriesResponse
GrpcBlobStorageClient

Client for gRPC blob storage communication

GrpcBlobStorageService

service for operation with data blob storage

GrpcBlobStorageService.GrpcBlobStorageServiceBase

Base class for server-side implementations of GrpcBlobStorageService

GrpcBlobStorageService.GrpcBlobStorageServiceClient

Client for GrpcBlobStorageService

GrpcClient

Client implementation for the Grpc connection.

GrpcMessage
GrpcReflectionServiceContractReflection

Holder for reflection information generated from Grpc/GrpcReflectionServiceContract.proto

GrpcReflectionServiceFactory

Creates a dynamic instance of the interface implemented on server to proxy the calls from grpc client service to grpc server.

GrpcServer

Server implementation for the Grpc connection.

GrpcService

general grpc service for bi-directional streaming messaging

GrpcService.GrpcServiceBase

Base class for server-side implementations of GrpcService

GrpcService.GrpcServiceClient

Client for GrpcService

GrpcMessage.Types

Container for nested types declared in the GrpcMessage message type.

VoidResponse

Interfaces

IGrpcBlobStorageClient
IGrpcClient
IGrpcCommunicator
IGrpcMessageHandler

Non generic implementation of IGrpcMessageHandler<T>

IGrpcMessageHandler<T>

Handles communication over Grpc.

IGrpcSender
IGrpcServer
IGrpcService

Enums

GrpcMessage.Types.MessageType