Class ExistResponse
- Namespace
- IdeaStatiCa.Plugin.Grpc
- Assembly
- IdeaStatiCa.Plugin.dll
public sealed class ExistResponse : IMessage<ExistResponse>, IEquatable<ExistResponse>, IDeepCloneable<ExistResponse>, IBufferMessage, IMessage
Inheritance
Implements
Inherited Members
Constructors
ExistResponse()
public ExistResponse()
ExistResponse(ExistResponse)
public ExistResponse(ExistResponse other)
Parameters
other
ExistResponse
Fields
ExistFieldNumber
Field number for the "exist" field.
public const int ExistFieldNumber = 1
Field Value
Properties
Descriptor
public static MessageDescriptor Descriptor { get; }
Property Value
Exist
public bool Exist { get; set; }
Property Value
Parser
public static MessageParser<ExistResponse> Parser { get; }
Property Value
Methods
CalculateSize()
Calculates the size of this message in Protocol Buffer wire format, in bytes.
public int CalculateSize()
Returns
- int
-
The number of bytes required to write this message to a coded output stream.
Clone()
Creates a deep clone of this object.
public ExistResponse Clone()
Returns
- ExistResponse
-
A deep clone of this object.
Equals(object)
Determines whether the specified object is equal to the current object.
public override bool Equals(object other)
Parameters
other
object
Returns
Equals(ExistResponse)
Indicates whether the current object is equal to another object of the same type.
public bool Equals(ExistResponse other)
Parameters
other
ExistResponse-
An object to compare with this object.
Returns
GetHashCode()
Serves as the default hash function.
public override int GetHashCode()
Returns
- int
-
A hash code for the current object.
MergeFrom(ExistResponse)
Merges the given message into this one.
public void MergeFrom(ExistResponse other)
Parameters
other
ExistResponse
Remarks
See the user guide for precise merge semantics.
MergeFrom(CodedInputStream)
Merges the data from the specified coded input stream with the current message.
public void MergeFrom(CodedInputStream input)
Parameters
input
CodedInputStream
Remarks
See the user guide for precise merge semantics.
ToString()
Returns a string that represents the current object.
public override string ToString()
Returns
- string
-
A string that represents the current object.
WriteTo(CodedOutputStream)
Writes the data to the given coded output stream.
public void WriteTo(CodedOutputStream output)
Parameters
output
CodedOutputStream-
Coded output stream to write the data to. Must not be null.