Table of Contents

Class ContentRequest

Namespace
IdeaStatiCa.Plugin.Grpc
Assembly
IdeaStatiCa.Plugin.dll
public sealed class ContentRequest : IMessage<ContentRequest>, IEquatable<ContentRequest>, IDeepCloneable<ContentRequest>, IBufferMessage, IMessage

Inheritance

Implements

Inherited Members

Constructors

ContentRequest()

public ContentRequest()

ContentRequest(ContentRequest)

public ContentRequest(ContentRequest other)

Parameters

other ContentRequest

Fields

BlobStorageIdFieldNumber

Field number for the "blobStorageId" field.

public const int BlobStorageIdFieldNumber = 1

Field Value

int

ContentIdFieldNumber

Field number for the "contentId" field.

public const int ContentIdFieldNumber = 2

Field Value

int

Properties

BlobStorageId

public string BlobStorageId { get; set; }

Property Value

string

ContentId

public string ContentId { get; set; }

Property Value

string

Descriptor

public static MessageDescriptor Descriptor { get; }

Property Value

MessageDescriptor

Parser

public static MessageParser<ContentRequest> Parser { get; }

Property Value

MessageParser<ContentRequest>

Methods

CalculateSize()

Calculates the size of this message in Protocol Buffer wire format, in bytes.

public int CalculateSize()

Returns

int

The number of bytes required to write this message to a coded output stream.

Clone()

Creates a deep clone of this object.

public ContentRequest Clone()

Returns

ContentRequest

A deep clone of this object.

Equals(object)

Determines whether the specified object is equal to the current object.

public override bool Equals(object other)

Parameters

other object

Returns

bool

true if the specified object is equal to the current object; otherwise, false.

Equals(ContentRequest)

Indicates whether the current object is equal to another object of the same type.

public bool Equals(ContentRequest other)

Parameters

other ContentRequest

An object to compare with this object.

Returns

bool

true if the current object is equal to the other parameter; otherwise, false.

GetHashCode()

Serves as the default hash function.

public override int GetHashCode()

Returns

int

A hash code for the current object.

MergeFrom(ContentRequest)

Merges the given message into this one.

public void MergeFrom(ContentRequest other)

Parameters

other ContentRequest

Remarks

See the user guide for precise merge semantics.

MergeFrom(CodedInputStream)

Merges the data from the specified coded input stream with the current message.

public void MergeFrom(CodedInputStream input)

Parameters

input CodedInputStream

Remarks

See the user guide for precise merge semantics.

ToString()

Returns a string that represents the current object.

public override string ToString()

Returns

string

A string that represents the current object.

WriteTo(CodedOutputStream)

Writes the data to the given coded output stream.

public void WriteTo(CodedOutputStream output)

Parameters

output CodedOutputStream

Coded output stream to write the data to. Must not be null.