Table of Contents

Class GrpcService

Namespace
IdeaStatiCa.Plugin.Grpc
Assembly
IdeaStatiCa.Plugin.dll

general grpc service for bi-directional streaming messaging

public static class GrpcService

Inheritance

Inherited Members

Properties

Descriptor

Service descriptor

public static ServiceDescriptor Descriptor { get; }

Property Value

ServiceDescriptor

Methods

BindService(GrpcServiceBase)

Creates service definition that can be registered with a server

public static ServerServiceDefinition BindService(GrpcService.GrpcServiceBase serviceImpl)

Parameters

serviceImpl GrpcService.GrpcServiceBase

An object implementing the server-side handling logic.

Returns

ServerServiceDefinition

BindService(ServiceBinderBase, GrpcServiceBase)

Register service method with a service binder with or without implementation. Useful when customizing the service binding logic. Note: this method is part of an experimental API that can change or be removed without any prior notice.

public static void BindService(ServiceBinderBase serviceBinder, GrpcService.GrpcServiceBase serviceImpl)

Parameters

serviceBinder ServiceBinderBase

Service methods will be bound by calling AddMethod on this object.

serviceImpl GrpcService.GrpcServiceBase

An object implementing the server-side handling logic.