Class GetEntriesResponse
- Namespace
- IdeaStatiCa.Plugin.Grpc
- Assembly
- IdeaStatiCa.Plugin.dll
public sealed class GetEntriesResponse : IMessage<GetEntriesResponse>, IEquatable<GetEntriesResponse>, IDeepCloneable<GetEntriesResponse>, IBufferMessage, IMessage
Inheritance
Implements
Inherited Members
Constructors
GetEntriesResponse()
public GetEntriesResponse()
GetEntriesResponse(GetEntriesResponse)
public GetEntriesResponse(GetEntriesResponse other)
Parameters
other
GetEntriesResponse
Fields
ContentIdFieldNumber
Field number for the "contentId" field.
public const int ContentIdFieldNumber = 1
Field Value
Properties
ContentId
public RepeatedField<string> ContentId { get; }
Property Value
Descriptor
public static MessageDescriptor Descriptor { get; }
Property Value
Parser
public static MessageParser<GetEntriesResponse> Parser { get; }
Property Value
Methods
CalculateSize()
Calculates the size of this message in Protocol Buffer wire format, in bytes.
public int CalculateSize()
Returns
- int
-
The number of bytes required to write this message to a coded output stream.
Clone()
Creates a deep clone of this object.
public GetEntriesResponse Clone()
Returns
- GetEntriesResponse
-
A deep clone of this object.
Equals(object)
Determines whether the specified object is equal to the current object.
public override bool Equals(object other)
Parameters
other
object
Returns
Equals(GetEntriesResponse)
Indicates whether the current object is equal to another object of the same type.
public bool Equals(GetEntriesResponse other)
Parameters
other
GetEntriesResponse-
An object to compare with this object.
Returns
GetHashCode()
Serves as the default hash function.
public override int GetHashCode()
Returns
- int
-
A hash code for the current object.
MergeFrom(GetEntriesResponse)
Merges the given message into this one.
public void MergeFrom(GetEntriesResponse other)
Parameters
other
GetEntriesResponse
Remarks
See the user guide for precise merge semantics.
MergeFrom(CodedInputStream)
Merges the data from the specified coded input stream with the current message.
public void MergeFrom(CodedInputStream input)
Parameters
input
CodedInputStream
Remarks
See the user guide for precise merge semantics.
ToString()
Returns a string that represents the current object.
public override string ToString()
Returns
- string
-
A string that represents the current object.
WriteTo(CodedOutputStream)
Writes the data to the given coded output stream.
public void WriteTo(CodedOutputStream output)
Parameters
output
CodedOutputStream-
Coded output stream to write the data to. Must not be null.