Table of Contents

Class GrpcService.GrpcServiceClient

Namespace
IdeaStatiCa.Plugin.Grpc
Assembly
IdeaStatiCa.Plugin.dll

Client for GrpcService

public class GrpcService.GrpcServiceClient : ClientBase<GrpcService.GrpcServiceClient>

Inheritance

Inherited Members

Constructors

GrpcServiceClient(ChannelBase)

Creates a new client for GrpcService

public GrpcServiceClient(ChannelBase channel)

Parameters

channel ChannelBase

The channel to use to make remote calls.

GrpcServiceClient(CallInvoker)

Creates a new client for GrpcService that uses a custom CallInvoker.

public GrpcServiceClient(CallInvoker callInvoker)

Parameters

callInvoker CallInvoker

The callInvoker to use to make remote calls.

GrpcServiceClient()

Protected parameterless constructor to allow creation of test doubles.

protected GrpcServiceClient()

GrpcServiceClient(ClientBaseConfiguration)

Protected constructor to allow creation of configured clients.

protected GrpcServiceClient(ClientBase.ClientBaseConfiguration configuration)

Parameters

configuration ClientBase.ClientBaseConfiguration

The client configuration.

Methods

ConnectAsync(Metadata, DateTime?, CancellationToken)

public virtual AsyncDuplexStreamingCall<GrpcMessage, GrpcMessage> ConnectAsync(Metadata headers = null, DateTime? deadline = null, CancellationToken cancellationToken = default)

Parameters

headers Metadata
deadline DateTime?
cancellationToken CancellationToken

Returns

AsyncDuplexStreamingCall<GrpcMessage, GrpcMessage>

ConnectAsync(CallOptions)

public virtual AsyncDuplexStreamingCall<GrpcMessage, GrpcMessage> ConnectAsync(CallOptions options)

Parameters

options CallOptions

Returns

AsyncDuplexStreamingCall<GrpcMessage, GrpcMessage>

NewInstance(ClientBaseConfiguration)

Creates a new instance of client from given ClientBaseConfiguration.

protected override GrpcService.GrpcServiceClient NewInstance(ClientBase.ClientBaseConfiguration configuration)

Parameters

configuration ClientBase.ClientBaseConfiguration

Returns

GrpcService.GrpcServiceClient