Table of Contents

Class GrpcBlobStorageService

Namespace
IdeaStatiCa.Plugin.Grpc
Assembly
IdeaStatiCa.Plugin.dll

service for operation with data blob storage

public static class GrpcBlobStorageService

Inheritance

Inherited Members

Properties

Descriptor

Service descriptor

public static ServiceDescriptor Descriptor { get; }

Property Value

ServiceDescriptor

Methods

BindService(GrpcBlobStorageServiceBase)

Creates service definition that can be registered with a server

public static ServerServiceDefinition BindService(GrpcBlobStorageService.GrpcBlobStorageServiceBase serviceImpl)

Parameters

serviceImpl GrpcBlobStorageService.GrpcBlobStorageServiceBase

An object implementing the server-side handling logic.

Returns

ServerServiceDefinition

BindService(ServiceBinderBase, GrpcBlobStorageServiceBase)

Register service method with a service binder with or without implementation. Useful when customizing the service binding logic. Note: this method is part of an experimental API that can change or be removed without any prior notice.

public static void BindService(ServiceBinderBase serviceBinder, GrpcBlobStorageService.GrpcBlobStorageServiceBase serviceImpl)

Parameters

serviceBinder ServiceBinderBase

Service methods will be bound by calling AddMethod on this object.

serviceImpl GrpcBlobStorageService.GrpcBlobStorageServiceBase

An object implementing the server-side handling logic.