Table of Contents

Class GrpcReflectionServer

Namespace
IdeaStatiCa.Plugin.Grpc.Reflection
Assembly
IdeaStatiCa.Plugin.dll

Instance of GrpcServer with Reflection Service added.

public class GrpcReflectionServer : GrpcServer, IGrpcServer, IGrpcCommunicator

Inheritance

Implements

Inherited Members

Constructors

GrpcReflectionServer(object, IPluginLogger, IBlobStorageProvider)

Creates a grpc reflection service for specified instance.

public GrpcReflectionServer(object instance, IPluginLogger logger, IBlobStorageProvider blobStorageProvider)

Parameters

instance object

Instance targeted by reflection calls.

logger IPluginLogger

pluginLogger

blobStorageProvider IBlobStorageProvider

Provider of blob storages