Table of Contents

Interface IApplicationBIM

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll

Abstraction of a FE application which provides data to Idea StatiCa

public interface IApplicationBIM

Methods

GetActiveSelection()

List<BIMItemId> GetActiveSelection()

Returns

List<BIMItemId>

GetActiveSelectionModelXML(CountryCode, RequestedItemsType)

string GetActiveSelectionModelXML(CountryCode countryCode, RequestedItemsType requestedType)

Parameters

countryCode CountryCode
requestedType RequestedItemsType

Returns

string

GetActiveSelectionModelXMLAsync(CountryCode, RequestedItemsType)

Task<string> GetActiveSelectionModelXMLAsync(CountryCode countryCode, RequestedItemsType requestedType)

Parameters

countryCode CountryCode
requestedType RequestedItemsType

Returns

Task<string>

GetApplicationName()

string GetApplicationName()

Returns

string

GetModelForSelectionXML(CountryCode, List<BIMItemsGroup>)

Returns a xml string representing a list of BIM models for requested sequence of given items - groups. Each group in the list of items represents designed item such as connection or member and is defined by the id, type and items belonging to the group. The item can also has id = -1, which means, that items (members or nodes typically) in this group doesn't belong to any design item (connection or member).

string GetModelForSelectionXML(CountryCode countryCode, List<BIMItemsGroup> items)

Parameters

countryCode CountryCode

The standard that will match the imported models.

items List<BIMItemsGroup>

The sequence of items, for which the BIM model is required.

Returns

string

A xml string representing a list of BIM models for requested items.

GetModelForSelectionXMLAsync(CountryCode, List<BIMItemsGroup>)

Task<string> GetModelForSelectionXMLAsync(CountryCode countryCode, List<BIMItemsGroup> items)

Parameters

countryCode CountryCode
items List<BIMItemsGroup>

Returns

Task<string>

IsCAD()

bool IsCAD()

Returns

bool

IsDataUpToDate()

bool IsDataUpToDate()

Returns

bool

SelectAsync(List<BIMItemId>)

Task SelectAsync(List<BIMItemId> items)

Parameters

items List<BIMItemId>

Returns

Task