Table of Contents

Namespace IdeaStatiCa.Plugin

Namespaces

IdeaStatiCa.Plugin.Exeptions
IdeaStatiCa.Plugin.Grpc
IdeaStatiCa.Plugin.Utilities

Classes

ApplicationBIM
AutomationHostingGrpc<MyInterface, ClientInterface>

Grpc Hosting implementation of AutomationHosting<MyInterface, ClientInterface>

AutomationService<ClientInterface>
BIMItemId
BIMItemsGroup
BIMPluginHostingGrpc

Grpc Implementation of BIMPluginHosting

BIMProject
ConnReportSettings

Settings of the content of a connection report

Constants
ConversionDictionary<TKey>
ConversionDictionaryInt
ConversionDictionaryString
CrossSectionProjectItem

Identification of an crossection item in the Idea project

GrpcBimHostingFactory
ISEventArgs
IdeaConnectionController
LibraryItem

Identification of an item in IDEA StatiCa MPRL (material and product range library)

ModelBIM
ProjectItem

Identification of an item in the Idea project

ReportResponse

The identifier of the generated report

SerializableDictionary<TKey, TVal>

SerializableDictionary

Tools

Interfaces

IApplicationBIM

Abstraction of a FE application which provides data to Idea StatiCa

IAutomation

This interface is used for controlling Idea Statica application from external applictions.

IBIMPluginClient<T>

Responsible for controlling the connected BIM application to IS

IBIMPluginFactory
IBIMPluginHosting
IBimHostingFactory
IClientBIM<B>
IConnHiddenCheck

Provides seamlessly data about connections or allows to run hidden calculation of a connection

IConnectionAutomation
IConnectionController

Automation of IdeaConnection app

IIdeaStaticaApp
IProgressCallback
IProgressMessaging

Enums

AppStatus
AutomationStatus
BIMItemType
LocalisedMessage
MessageSeverity
RequestedItemsType

Delegates

ISEventHandler