Table of Contents

Interface IProgressCallback

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll
public interface IProgressCallback

Methods

ExceptionMessage(string, Exception)

Method is called when an exception occurs on the server.

void ExceptionMessage(string function, Exception exception)

Parameters

function string

Name of the method.

exception Exception

Details of the exception

IterationMessage(double, string, string)

infomation about progress of event.

void IterationMessage(double percent, string message, string iteration)

Parameters

percent double

percentage of event status

message string

message

iteration string

Number of the iteration (FEM solver steps)

ProgressMessage(double, string)

infomation about progress of event.

void ProgressMessage(double percent, string message)

Parameters

percent double

percentage of event status

message string

message