Table of Contents

Class BIMPluginHostingGrpc

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll

Grpc Implementation of BIMPluginHosting

public class BIMPluginHostingGrpc : IBIMPluginHosting, IDisposable

Inheritance

Implements

Inherited Members

Constructors

BIMPluginHostingGrpc(IBIMPluginFactory, IGrpcServer, IPluginLogger, string)

public BIMPluginHostingGrpc(IBIMPluginFactory factory, IGrpcServer grpcServer, IPluginLogger logger = null, string eventName = "IdeaStatiCaBIMPluginEvent")

Parameters

factory IBIMPluginFactory
grpcServer IGrpcServer
logger IPluginLogger
eventName string

Properties

EventName

System event name.

public string EventName { get; set; }

Property Value

string

GrpcServer

public GrpcReflectionServer GrpcServer { get; }

Property Value

GrpcReflectionServer

IdeaStaticaApp

App process

public Process IdeaStaticaApp { get; set; }

Property Value

Process

Service

BIM Service.

public IApplicationBIM Service { get; set; }

Property Value

IApplicationBIM

Methods

Dispose(bool)

Disposes current plugin host.

protected virtual void Dispose(bool disposing)

Parameters

disposing bool

Dispose()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose()

RunAsync(string, string)

public Task RunAsync(string id, string workingDirectory)

Parameters

id string
workingDirectory string

Returns

Task

Stop()

Stops the plugin host.

public void Stop()

AppStatusChanged

Triggered when app status changes.

public event ISEventHandler AppStatusChanged

Event Type

ISEventHandler