Table of Contents

Interface IBIMPluginHosting

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll
public interface IBIMPluginHosting

Properties

Service

IApplicationBIM Service { get; }

Property Value

IApplicationBIM

Methods

RunAsync(string, string)

Task RunAsync(string id, string workingDirectory)

Parameters

id string
workingDirectory string

Returns

Task

AppStatusChanged

event ISEventHandler AppStatusChanged

Event Type

ISEventHandler