Table of Contents

Class ApplicationBIM

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll
public abstract class ApplicationBIM : IApplicationBIM

Inheritance

Implements

Inherited Members

Constructors

ApplicationBIM()

Default contructor

public ApplicationBIM()

ApplicationBIM(IPluginLogger)

Constructor for injecting the instance of a pluginLogger

public ApplicationBIM(IPluginLogger logger)

Parameters

logger IPluginLogger

The wrapper for pluginLogger

Fields

ideaLoggerBase

protected IPluginLogger ideaLoggerBase

Field Value

IPluginLogger

Properties

ApplicationName

protected abstract string ApplicationName { get; }

Property Value

string

Id

public int Id { get; }

Property Value

int

IdeaStaticaApp

communication canal for sending message to the checkbot

public IIdeaStaticaApp IdeaStaticaApp { get; set; }

Property Value

IIdeaStaticaApp

Progress

communication canal for sending progress messages

public IProgressMessaging Progress { get; set; }

Property Value

IProgressMessaging

Methods

ActivateInBIM(List<BIMItemId>)

public abstract void ActivateInBIM(List<BIMItemId> items)

Parameters

items List<BIMItemId>

GetActiveSelection()

public virtual List<BIMItemId> GetActiveSelection()

Returns

List<BIMItemId>

GetActiveSelectionModel(CountryCode, RequestedItemsType)

public ModelBIM GetActiveSelectionModel(CountryCode countryCode, RequestedItemsType requestedType)

Parameters

countryCode CountryCode
requestedType RequestedItemsType

Returns

ModelBIM

GetActiveSelectionModelXML(CountryCode, RequestedItemsType)

public string GetActiveSelectionModelXML(CountryCode countryCode, RequestedItemsType requestedType)

Parameters

countryCode CountryCode
requestedType RequestedItemsType

Returns

string

GetActiveSelectionModelXMLAsync(CountryCode, RequestedItemsType)

public Task<string> GetActiveSelectionModelXMLAsync(CountryCode countryCode, RequestedItemsType requestedType)

Parameters

countryCode CountryCode
requestedType RequestedItemsType

Returns

Task<string>

GetApplicationName()

public string GetApplicationName()

Returns

string

GetModelForSelection(CountryCode, List<BIMItemsGroup>)

public List<ModelBIM> GetModelForSelection(CountryCode countryCode, List<BIMItemsGroup> items)

Parameters

countryCode CountryCode
items List<BIMItemsGroup>

Returns

List<ModelBIM>

GetModelForSelectionXML(CountryCode, List<BIMItemsGroup>)

Returns a xml string representing a list of BIM models for requested sequence of given items - groups. Each group in the list of items represents designed item such as connection or member and is defined by the id, type and items belonging to the group. The item can also has id = -1, which means, that items (members or nodes typically) in this group doesn't belong to any design item (connection or member).

public string GetModelForSelectionXML(CountryCode countryCode, List<BIMItemsGroup> items)

Parameters

countryCode CountryCode

The standard that will match the imported models.

items List<BIMItemsGroup>

The sequence of items, for which the BIM model is required.

Returns

string

A xml string representing a list of BIM models for requested items.

GetModelForSelectionXMLAsync(CountryCode, List<BIMItemsGroup>)

public Task<string> GetModelForSelectionXMLAsync(CountryCode countryCode, List<BIMItemsGroup> items)

Parameters

countryCode CountryCode
items List<BIMItemsGroup>

Returns

Task<string>

ImportActive(CountryCode, RequestedItemsType)

protected abstract ModelBIM ImportActive(CountryCode countryCode, RequestedItemsType requestedType)

Parameters

countryCode CountryCode
requestedType RequestedItemsType

Returns

ModelBIM

ImportSelection(CountryCode, List<BIMItemsGroup>)

protected abstract List<ModelBIM> ImportSelection(CountryCode countryCode, List<BIMItemsGroup> items)

Parameters

countryCode CountryCode
items List<BIMItemsGroup>

Returns

List<ModelBIM>

IsCAD()

public virtual bool IsCAD()

Returns

bool

IsDataUpToDate()

public virtual bool IsDataUpToDate()

Returns

bool

SelectAsync(List<BIMItemId>)

public Task SelectAsync(List<BIMItemId> items)

Parameters

items List<BIMItemId>

Returns

Task