Table of Contents

Interface IIdeaStaticaApp

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll
public interface IIdeaStaticaApp : IProgressMessaging

Implements

Methods

GetAllConnectionData(int)

Get structural data and corresponding results of FE analysis for connectionId

string GetAllConnectionData(int connectionId)

Parameters

connectionId int

Identifier of the required connection

Returns

string

XML string which prepresents the instance of of IdeaRS.OpenModel.OpenModelContainer (stuctural data and results of FE analysis)

Exceptions

Exception

Exception is thrown if operation fails or no data are provided by the service

GetConnectionModel(int)

Get connection model in IOM format

ConnectionData GetConnectionModel(int connectionId)

Parameters

connectionId int

The ID of the connection in the project

Returns

ConnectionData

Connection model

Exceptions

Exception

Exception is thrown if operation fails or no data are provided by the service

GetCssInMPRL(CountryCode)

Get all cross-sections from IDEA StatiCa MPRL (material and product range library) which belongs to countryCode

List<LibraryItem> GetCssInMPRL(CountryCode countryCode)

Parameters

countryCode CountryCode

Country code filter

Returns

List<LibraryItem>

Cross-sections in the MPRL

GetCssInProject()

Get all cross-sections in the currently open project

List<ProjectItem> GetCssInProject()

Returns

List<ProjectItem>

Cross-sections in the project

GetCssInProjectV2()

Get all cross-sections in the currently open project

List<CrossSectionProjectItem> GetCssInProjectV2()

Returns

List<CrossSectionProjectItem>

Cross-sections with assigned material in the project

GetMaterialsInMPRL(CountryCode)

Get all materials from IDEA StatiCa MPRL (material and product range library) which belongs to countryCode

List<LibraryItem> GetMaterialsInMPRL(CountryCode countryCode)

Parameters

countryCode CountryCode

Country code filter

Returns

List<LibraryItem>

Materials in the MPRL

GetMaterialsInProject()

Get all materials in the currently open project

List<ProjectItem> GetMaterialsInProject()

Returns

List<ProjectItem>

Materials in the project