Table of Contents

Class AutomationService<ClientInterface>

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll
public class AutomationService<ClientInterface> : IAutomation, IClientBIM<ClientInterface>, IDisposable

Type Parameters

ClientInterface

Inheritance

Implements

Inherited Members

Constructors

AutomationService()

public AutomationService()

Properties

BIM

public ClientInterface BIM { get; set; }

Property Value

ClientInterface

ProjectDir

public virtual string ProjectDir { get; }

Property Value

string

Status

public AutomationStatus Status { get; protected set; }

Property Value

AutomationStatus

TempWorkingDir

public virtual string TempWorkingDir { get; }

Property Value

string

Methods

CloseProject()

Close the project

public void CloseProject()

CloseProjectAsync()

Close the project

public virtual Task CloseProjectAsync()

Returns

Task

Dispose(bool)

protected virtual void Dispose(bool disposing)

Parameters

disposing bool

Dispose()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose()

NotifyChange()

public virtual void NotifyChange()

OpenProject(string, string)

It calls IdeaStatiCa.Plugin.AutomationService`1.OpenProjectAsync(System.String,System.String)"/>

public virtual void OpenProject(string fileName, string optionalParamJson)

Parameters

fileName string
optionalParamJson string

OpenProjectAsync(string, string)

Empty virtual implementation - does nothing

public virtual Task OpenProjectAsync(string fileName, string optionalParamJson)

Parameters

fileName string

Project to open

optionalParamJson string

Returns

Task

Refresh()

public void Refresh()

RefreshAsync()

public virtual Task RefreshAsync()

Returns

Task

RefreshProject()

Refresh the currently open project

public void RefreshProject()

RefreshProjectAsync()

Refresh the currently open project

public virtual Task RefreshProjectAsync()

Returns

Task

SelectItem(string)

Select item with itemId in the project

public virtual void SelectItem(string itemId)

Parameters

itemId string

The identifier of the requested item

Shutdown()

public virtual void Shutdown()