Table of Contents

Interface IAutomation

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll

This interface is used for controlling Idea Statica application from external applictions.

public interface IAutomation

Properties

ProjectDir

string ProjectDir { get; }

Property Value

string

Status

AutomationStatus Status { get; }

Property Value

AutomationStatus

TempWorkingDir

string TempWorkingDir { get; }

Property Value

string

Methods

CloseProject()

Close the project

void CloseProject()

CloseProjectAsync()

Close the project

Task CloseProjectAsync()

Returns

Task

NotifyChange()

void NotifyChange()

OpenProject(string, string)

Open the project fileName

void OpenProject(string fileName, string optionalParamJson)

Parameters

fileName string

Project to open

optionalParamJson string

json string which can include optional parameters for a module

OpenProjectAsync(string, string)

Open the project fileName

Task OpenProjectAsync(string fileName, string optionalParamJson)

Parameters

fileName string

Project to open

optionalParamJson string

json string which can include optional parameters for a module

Returns

Task

Task

Refresh()

void Refresh()

RefreshAsync()

Task RefreshAsync()

Returns

Task

RefreshProject()

Refresh the currently open project

void RefreshProject()

RefreshProjectAsync()

Refresh the currently open project

Task RefreshProjectAsync()

Returns

Task

SelectItem(string)

Select item with itemId in the project

void SelectItem(string itemId)

Parameters

itemId string

The identifier of the requested item

Shutdown()

void Shutdown()