Table of Contents

Class IdeaConnectionController

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll
public class IdeaConnectionController : IDisposable, IConnectionController

Inheritance

Implements

Inherited Members

Constructors

IdeaConnectionController(string, IPluginLogger)

protected IdeaConnectionController(string ideaInstallDir, IPluginLogger logger)

Parameters

ideaInstallDir string
logger IPluginLogger

Fields

CurrentItemChangedEvent

protected EventWaitHandle CurrentItemChangedEvent

Field Value

EventWaitHandle

Properties

GrpcClient

protected AutomationHostingGrpc<IAutomation, IAutomation> GrpcClient { get; set; }

Property Value

AutomationHostingGrpc<IAutomation, IAutomation>

UserMode

protected virtual uint UserMode { get; }

Property Value

uint

Methods

CloseProject()

Close the open project

public int CloseProject()

Returns

int

CloseProjectAsync()

Close the open project

public Task<int> CloseProjectAsync()

Returns

Task<int>

Create(string)

Creates connection and starts IDEA StatiCa connection application. Call OpenProjectAsync after this method to open specific project.

public static IConnectionController Create(string ideaInstallDir)

Parameters

ideaInstallDir string

IDEA StatiCa installation directory.

Returns

IConnectionController

A controller object.

Create(string, IPluginLogger)

Creates connection and starts IDEA StatiCa connection application. Call OpenProjectAsync after this method to open specific project.

public static IConnectionController Create(string ideaInstallDir, IPluginLogger logger)

Parameters

ideaInstallDir string

IDEA StatiCa installation directory.

logger IPluginLogger

The pluginLogger.

Returns

IConnectionController

A controller object.

Dispose(bool)

protected virtual void Dispose(bool disposing)

Parameters

disposing bool

Dispose()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose()

GeneratePdfReport(int, string, ConnReportSettings)

Send a request to generate connection report in PDF document

public void GeneratePdfReport(int conId, string filePath, ConnReportSettings settings)

Parameters

conId int

Id of the requested connection

filePath string

File path of exported pdf report

settings ConnReportSettings

Report settings

GeneratePdfReportStorage(int, ConnReportSettings)

Generate PDF report blob storage

public IBlobStorage GeneratePdfReportStorage(int conId, ConnReportSettings settings)

Parameters

conId int

Id of the requested connection

settings ConnReportSettings

Report settings

Returns

IBlobStorage

GenerateReport(int, ConnReportSettings)

public IBlobStorage GenerateReport(int conId, ConnReportSettings settings)

Parameters

conId int
settings ConnReportSettings

Returns

IBlobStorage

GenerateWordReport(int, string, ConnReportSettings)

Send a request to generate connection report as Word document

public void GenerateWordReport(int conId, string filePath, ConnReportSettings settings)

Parameters

conId int

Id of the requested connection

filePath string

File path of exported word report

settings ConnReportSettings

Report settings

GenerateWordReportStorage(int, ConnReportSettings)

Generate Word report blob storage

public IBlobStorage GenerateWordReportStorage(int conId, ConnReportSettings settings)

Parameters

conId int

Id of the requested connection

settings ConnReportSettings

Report settings

Returns

IBlobStorage

OpenConnectionClient()

protected void OpenConnectionClient()

OpenProject(string)

Open idea con project in IdeaConnection

public int OpenProject(string fileName)

Parameters

fileName string

The file path to the ideaCon.

Returns

int

ConnectionAppExited

Fires when IdeaConnection app exited.

public event EventHandler ConnectionAppExited

Event Type

EventHandler