Table of Contents

Class AutomationHostingGrpc<MyInterface, ClientInterface>

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll

Grpc Hosting implementation of AutomationHosting<MyInterface, ClientInterface>

public class AutomationHostingGrpc<MyInterface, ClientInterface> : IGrpcCommunicationCommonInterface, IBIMPluginClient<ClientInterface>, IDisposable where MyInterface : class where ClientInterface : class

Type Parameters

MyInterface
ClientInterface

Inheritance

Implements

Inherited Members

Constructors

AutomationHostingGrpc(MyInterface, IGrpcClient, IPluginLogger, string)

public AutomationHostingGrpc(MyInterface hostedService, IGrpcClient grpcClient, IPluginLogger logger = null, string eventName = "IdeaStatiCaBIMPluginEvent")

Parameters

hostedService MyInterface
grpcClient IGrpcClient
logger IPluginLogger
eventName string

Properties

EventName

protected string EventName { get; set; }

Property Value

string

GrpcClient

public IGrpcClient GrpcClient { get; }

Property Value

IGrpcClient

IsConnected

Determines whether BIM application is connected.

public bool IsConnected { get; }

Property Value

bool

MyBIM

My BIM object.

public ClientInterface MyBIM { get; set; }

Property Value

ClientInterface

Status

Current automation status.

public AutomationStatus Status { get; }

Property Value

AutomationStatus

Methods

Dispose()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose()

Dispose(bool)

protected virtual void Dispose(bool disposing)

Parameters

disposing bool

NotifyBIMStatusChanged(AppStatus)

protected virtual void NotifyBIMStatusChanged(AppStatus newStatus)

Parameters

newStatus AppStatus

RunAsync(string)

public Task RunAsync(string id)

Parameters

id string

Returns

Task

RunServerAsync(string, CancellationToken)

protected virtual Task RunServerAsync(string id, CancellationToken cancellationToken)

Parameters

id string
cancellationToken CancellationToken

Returns

Task

Stop()

Stops BIM application

public void Stop()

BIMStatusChanged

Triggered when BIM status changes.

public event ISEventHandler BIMStatusChanged

Event Type

ISEventHandler