Table of Contents

Interface IConnHiddenCheck

Namespace
IdeaStatiCa.Plugin
Assembly
IdeaStatiCa.Plugin.dll

Provides seamlessly data about connections or allows to run hidden calculation of a connection

public interface IConnHiddenCheck

Methods

AddBoltAssembly(string)

Add the new bolt assembly. Its type is defined by its name (e.g. 'M12 4.6')

int AddBoltAssembly(string boltAssemblyName)

Parameters

boltAssemblyName string

Returns

int

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

AddBoltAssemblyAsynchronous(string)

Add the new bolt assembly. Its type is defined by its name (e.g. 'M12 4.6')

Task<int> AddBoltAssemblyAsynchronous(string boltAssemblyName)

Parameters

boltAssemblyName string

Returns

Task<int>

ApplyParameters(string, string)

Apply parametersJSON on connectionconnectionId IOM Parameters

string ApplyParameters(string connectionId, string parametersJSON)

Parameters

connectionId string

Id of the parameter

parametersJSON string

JSON string including parameters

Returns

string

True if success | False if apply of parameters failed OR model contain some nonconformity

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

ApplyParametersAsynchronous(string, string)

Apply parametersJSON on connectionconnectionId IOM Parameters

Task<string> ApplyParametersAsynchronous(string connectionId, string parametersJSON)

Parameters

connectionId string

Id of the parameter

parametersJSON string

JSON string including parameters

Returns

Task<string>

True if success | False if apply of parameters failed OR model contain some nonconformity

ApplySimpleTemplate(string, string, ApplyConnTemplateSetting, int, List<int>)

Apply the simple connectionsimple template from file templateFilePath on connection connectionId

string ApplySimpleTemplate(string connectionId, string templateFilePath, ApplyConnTemplateSetting connTemplateSetting, int mainMember, List<int> attachedMembers)

Parameters

connectionId string

The id of the connection on which templete will be applied

templateFilePath string

The path to the connection teplate

connTemplateSetting ApplyConnTemplateSetting

The additional settings - e.g. default bolts

mainMember int

Main (supporting member)

attachedMembers List<int>

The list of members which are supported by mainMember

Returns

string

Returns 'Ok' in case of the success otherwise 'Fail'

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

ApplySimpleTemplateAsynchronous(string, string, ApplyConnTemplateSetting, int, List<int>)

Apply the simple connectionsimple template from file templateFilePath on connection connectionId

Task<string> ApplySimpleTemplateAsynchronous(string connectionId, string templateFilePath, ApplyConnTemplateSetting connTemplateSetting, int mainMember, List<int> attachedMembers)

Parameters

connectionId string

The id of the connection on which templete will be applied

templateFilePath string

The path to the connection teplate

connTemplateSetting ApplyConnTemplateSetting

The additional settings - e.g. default bolts

mainMember int

Main (supporting member)

attachedMembers List<int>

The list of members which are supported by mainMember

Returns

Task<string>

Returns 'Ok' in case of the success otherwise 'Fail'

ApplyTemplate(string, string, ApplyConnTemplateSetting)

Apply the selected template in file conTemplateFileName on connection connectionId

string ApplyTemplate(string connectionId, string conTemplateFileName, ApplyConnTemplateSetting connTemplateSetting)

Parameters

connectionId string

Identifier of the connection in the project, empty guid means the first connection in the project

conTemplateFileName string

contemp filename including connection template

connTemplateSetting ApplyConnTemplateSetting

Additional setting for application of the template.

Returns

string

returns 'OK' if success otherwise an error message

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

ApplyTemplateAsynchronous(string, string, ApplyConnTemplateSetting)

Apply the selected template in file conTemplateFileName on connection connectionId

Task<string> ApplyTemplateAsynchronous(string connectionId, string conTemplateFileName, ApplyConnTemplateSetting connTemplateSetting)

Parameters

connectionId string

Identifier of the connection in the project, empty guid means the first connection in the project

conTemplateFileName string

contemp filename including connection template

connTemplateSetting ApplyConnTemplateSetting

Additional setting for application of the template.

Returns

Task<string>

returns 'OK' if success otherwise an error message

Calculate(string)

Cakculate connection given by connectionId

ConnectionResultsData Calculate(string connectionId)

Parameters

connectionId string

The identifier of the required connection

Returns

ConnectionResultsData

Connection check results

CalculateBuckling(string)

ConnectionResultsData CalculateBuckling(string connectionId)

Parameters

connectionId string

Returns

ConnectionResultsData

Cancel()

Cancel current calcullation

void Cancel()

CloseProject()

Close project which is open in the service

void CloseProject()

CreateConProjFromIOM(string, string, string)

Creates Idea connection project from given iomXmlFileName, iomResXmlFileName and projects saves into the newIdeaConFileName

void CreateConProjFromIOM(string iomXmlFileName, string iomResXmlFileName, string newIdeaConFileName)

Parameters

iomXmlFileName string

Filename of a given IOM xml file

iomResXmlFileName string

Filename of a given IOM Result xml file

newIdeaConFileName string

File name of idea connection project where generated project will be saved

DeleteAllOperations(string)

Delete all manufacturing operations in connectionId

string DeleteAllOperations(string connectionId)

Parameters

connectionId string

Id of the connection

Returns

string

Returns 'Ok' in case of the success otherwise 'Fail'

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

DeleteAllOperationsAsynchronous(string)

Delete all manufacturing operations in connectionId

Task<string> DeleteAllOperationsAsynchronous(string connectionId)

Parameters

connectionId string

Id of the connection

Returns

Task<string>

Returns 'Ok' in case of the success otherwise 'Fail'

EvaluateExpression(string, string, string)

Evaluate expression on connection model connectionId

string EvaluateExpression(string connectionId, string expression, string arumentsJSON)

Parameters

connectionId string

Id of the connection in the open idea connection project

expression string

User expression to be evaluated

arumentsJSON string

Optional agruments in json format (not used now)

Returns

string

In case of a success it is the JSON string representing the result of the query. String 'null' if nothing is found. String 'error' in case of any other unspecified error.

ExportToTemplate(string, string)

Export the manufacture sequence of connectionId as a template and save it in conTemplateFileName (.contemp file)

string ExportToTemplate(string connectionId, string conTemplateFileName)

Parameters

connectionId string

Identifier of the connection in the project, empty guid means the first connection in the project

conTemplateFileName string

The file name of the output file

Returns

string

returns 'OK' if success otherwise an error message

GenerateReport(string, ConnReportSettings)

Generate a report for connection connectionId

ReportResponse GenerateReport(string connectionId, ConnReportSettings settings)

Parameters

connectionId string

The unique identifier of the requested connection

settings ConnReportSettings

Report settings

Returns

ReportResponse

The identifier of the generated report. It will be used in GrpcBlobStorageClient requests

GenerateReportPdf(string, string, ConnReportSettings)

Generate a pdf report for connection connectionId

void GenerateReportPdf(string connectionId, string filePath, ConnReportSettings settings)

Parameters

connectionId string

The unique identifier of the requested connection

filePath string

File path of the exported pdf report

settings ConnReportSettings

Report settings

GenerateReportWord(string, string, ConnReportSettings)

Generate a word report for connection connectionId

void GenerateReportWord(string connectionId, string filePath, ConnReportSettings settings)

Parameters

connectionId string

The unique identifier of the requested connection

filePath string

File path of the exported word report

settings ConnReportSettings

Report settings

GetAllConnectionData(string)

Get structural data and corresponding results of FE analysi for connectionId

string GetAllConnectionData(string connectionId)

Parameters

connectionId string

Identifier of the required connection

Returns

string

XML string which prepresents the instance of of IdeaRS.OpenModel.OpenModelContainer (stuctural data and results of FE analysis)

GetBoltAssembliesInProject()

Get all bolt assemblies in the currently open project

List<ProjectItem> GetBoltAssembliesInProject()

Returns

List<ProjectItem>

Bolt assemblies in the project

GetCheckResultsJSON(string)

Get the details results of the connection connectionId

string GetCheckResultsJSON(string connectionId)

Parameters

connectionId string

Id of the connection

Returns

string

Json which represents

GetCodeSetupJSON()

Get code setup in JSON format IOM connection setup

string GetCodeSetupJSON()

Returns

string

GetConnectionCost(string)

Gets connection price given by connectionId

string GetConnectionCost(string connectionId)

Parameters

connectionId string

The identifier of the required connection

Returns

string

Connection price results

GetConnectionLoadingJSON(string)

Get loading for connection connectionId (List of CalcCaseData)

string GetConnectionLoadingJSON(string connectionId)

Parameters

connectionId string

Id of the parameter

Returns

string

GetConnectionModel(string)

Get the geometry of the connectionId

ConnectionData GetConnectionModel(string connectionId)

Parameters

connectionId string

Identifier of the required connection

Returns

ConnectionData

Geometry of the connection in the IOM format

GetConnectionModelXML(string)

Get the geometry of the connectionId

string GetConnectionModelXML(string connectionId)

Parameters

connectionId string

Identifier of the required connection

Returns

string

Geometry of the connection in the Xml format

GetCrossSectionsInProject()

Get all cross-sections in the currently open project

List<ProjectItem> GetCrossSectionsInProject()

Returns

List<ProjectItem>

Cross-sections in the project

GetMaterialsInProject()

Get all materials in the currently open project

List<ProjectItem> GetMaterialsInProject()

Returns

List<ProjectItem>

Materials in the project

GetParametersJSON(string)

Get list of parameters in JSON format for connectionId IOM Parameters

string GetParametersJSON(string connectionId)

Parameters

connectionId string

Id of the parameter

Returns

string

GetProjectInfo()

Gets details about the open project and its connections

ConProjectInfo GetProjectInfo()

Returns

ConProjectInfo

OpenConnectionInApp(string)

Open and select the connection connectionId in an application

void OpenConnectionInApp(string connectionId)

Parameters

connectionId string

The unique identifier of the requested connection

OpenProject(string)

Open idea project in the service

void OpenProject(string ideaConProject)

Parameters

ideaConProject string

Idea Connection project.

Save()

Saves the current data

void Save()

SaveAsProject(string)

Save the current data in file newProjectFileName

void SaveAsProject(string newProjectFileName)

Parameters

newProjectFileName string

File name of the new idea connection project

SetCrossSectionMaterial(int, int)

Change the material of a cross-section currently available in the Project

void SetCrossSectionMaterial(int crossSectionId, int materialId)

Parameters

crossSectionId int

Id of the cross-section

materialId int

Id of the material

SetMemberCrossSection(string, int, int)

Change the cross-section of a member in a connection in the Project through

void SetMemberCrossSection(string connectionId, int memberId, int crossSectionId)

Parameters

connectionId string

Id of the connection

memberId int

Id of the member

crossSectionId int

Id of the cross-section

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

SetMemberCrossSectionAsynchronous(string, int, int)

Change the cross-section of a member in a connection in the Project through

Task SetMemberCrossSectionAsynchronous(string connectionId, int memberId, int crossSectionId)

Parameters

connectionId string

Id of the connection

memberId int

Id of the member

crossSectionId int

Id of the cross-section

Returns

Task

UpdateCodeSetupJSON(string)

Set codesetup for the connection

string UpdateCodeSetupJSON(string connectionSetupJSON)

Parameters

connectionSetupJSON string

connection setup in JSON format

Returns

string

UpdateCodeSetupJsonAsynchronous(string)

Set codesetup for the connection

Task<string> UpdateCodeSetupJsonAsynchronous(string connectionSetupJSON)

Parameters

connectionSetupJSON string

connection setup in JSON format

Returns

Task<string>

UpdateConProjFromIOM(string, string)

Update opened Idea connection project from given iomXmlFileName, iomResXmlFileName

void UpdateConProjFromIOM(string iomXmlFileName, string iomResXmlFileName)

Parameters

iomXmlFileName string

Filename of a given IOM xml file

iomResXmlFileName string

Filename of a given IOM Result xml file

UpdateLoadingFromJson(string, string)

Set loading for the connection

string UpdateLoadingFromJson(string connectionId, string loadingJSON)

Parameters

connectionId string

Id of the connection

loadingJSON string

JSON including list of CalcCaseData

Returns

string

Remarks

This synchronous method internally invokes the asynchronous code, which might cause application freezes and failures when run on the UI thread. When you attempt to run this method on the UI thread, run the asynchronous version of this method instead using the await keyword.

UpdateLoadingFromJsonAsynchronous(string, string)

Set loading for the connection

Task<string> UpdateLoadingFromJsonAsynchronous(string connectionId, string loadingJSON)

Parameters

connectionId string

Id of the connection

loadingJSON string

JSON including list of CalcCaseData

Returns

Task<string>