Table of Contents

Class PortFinder

Namespace
IdeaStatiCa.Plugin.Utilities
Assembly
IdeaStatiCa.Plugin.dll

Tool used to find a free port for gRPC communication.

public static class PortFinder

Inheritance

Inherited Members

Methods

FindPort(int, int, IPluginLogger)

Searches for the next available tcp port on the localhost.

public static int FindPort(int minPort, int maxPort, IPluginLogger pluginLogger = null)

Parameters

minPort int

Initial port to start the search from.

maxPort int

The last available tcp port

pluginLogger IPluginLogger

Optional logger

Returns

int

Exceptions

ArgumentException
Exception