Table of Contents

Class GrpcReflectionArgument

Namespace
IdeaStatiCa.Plugin.Grpc.Reflection
Assembly
IdeaStatiCa.Plugin.dll

Represents an argument that Grpc will use to call the method invoked via reflection.

public class GrpcReflectionArgument

Inheritance

Inherited Members

Extension Methods

Constructors

GrpcReflectionArgument(string, object)

Initializes a reflection argument with specified parameters.

public GrpcReflectionArgument(string type, object value)

Parameters

type string
value object

GrpcReflectionArgument()

Initializes an empty GrpcReflectionArgument

public GrpcReflectionArgument()

Properties

ParameterType

FullName of the arguments value type.

public string ParameterType { get; set; }

Property Value

string

Value

Value of the argument.

public object Value { get; set; }

Property Value

object