Table of Contents

Class GrpcServiceBasedReflectionClient<IReflectionService>

Namespace
IdeaStatiCa.Plugin.Grpc.Reflection
Assembly
IdeaStatiCa.Plugin.dll

WCF-like implementation of the GrpcReflectionClient that uses interceptors to proxy calls to server.

public class GrpcServiceBasedReflectionClient<IReflectionService> : GrpcClient, IGrpcClient, IGrpcCommunicator, IGrpcService, IGrpcSender where IReflectionService : class

Type Parameters

IReflectionService

Inheritance

Implements

Inherited Members

Constructors

GrpcServiceBasedReflectionClient(IPluginLogger)

public GrpcServiceBasedReflectionClient(IPluginLogger logger)

Parameters

logger IPluginLogger

Properties

Service

Service used to call server methods.

public IReflectionService Service { get; }

Property Value

IReflectionService