Table of Contents

Class GrpcServiceClient<ServiceType>

Namespace
IdeaStatiCa.Plugin.Grpc.Reflection
Assembly
IdeaStatiCa.Plugin.dll

Client of the service which is hosted by gRPC server

public class GrpcServiceClient<ServiceType> where ServiceType : class

Type Parameters

ServiceType

Inheritance

Inherited Members

Constructors

GrpcServiceClient(string, IGrpcService, IPluginLogger)

Constructor

public GrpcServiceClient(string handlerName, IGrpcService grpcService, IPluginLogger logger)

Parameters

handlerName string

Handler name

grpcService IGrpcService

gRPC service of the gRPC server

logger IPluginLogger

Fields

HandlerName

public readonly string HandlerName

Field Value

string

Properties

Service

Client of the service

public ServiceType Service { get; }

Property Value

ServiceType