Table of Contents

Class ReflectionHelper

Namespace
IdeaStatiCa.Plugin.Utilities
Assembly
IdeaStatiCa.Plugin.dll

Helper for reflection methods used by gRPC.

public static class ReflectionHelper

Inheritance

Inherited Members

Methods

GetLoadedType(string)

TODO - how to get the type from the string fullName correctly ?

public static Type GetLoadedType(string fullName)

Parameters

fullName string

Returns

Type

GetMethodInvokeArguments(params object[])

Gets a gRPC message for invoking method.

public static IEnumerable<GrpcReflectionArgument> GetMethodInvokeArguments(params object[] args)

Parameters

args object[]

Returns

IEnumerable<GrpcReflectionArgument>

InvokeMethodFromGrpc(object, string, IEnumerable<GrpcReflectionArgument>)

Invokes method based on parameters passed from grpc message.

public static Task<object> InvokeMethodFromGrpc(object instance, string methodName, IEnumerable<GrpcReflectionArgument> arguments)

Parameters

instance object
methodName string
arguments IEnumerable<GrpcReflectionArgument>

Returns

Task<object>

IsSimpleType(Type)

Determine whether the target type is simple type.

public static bool IsSimpleType(Type type)

Parameters

type Type

Type to check

Returns

bool