Table of Contents

ideastatica-rcs-api

The Python package for the RCS Rest API 1.0

  • API version: 1.0
  • Package version: 25.0.1.0960

IDEA StatiCa RCS API, used for the automated design and calculation of reinforced concrete sections.

Requirements.

Python 3.7+

Installation

pip install

We reccomend using pip to install the package into your environment.

pip install ideastatica_rcs_api

Then import the package in your project:

import ideastatica_rcs_api

If the python package is hosted on a repository, you can install directly using:

pip install git+https://github.com/GIT_USER_ID/GIT_REPO_ID.git

(you may need to run pip with root permission: sudo pip install git+https://github.com/GIT_USER_ID/GIT_REPO_ID.git)

Setuptools

Install via Setuptools.

python setup.py install --user

(or sudo python setup.py install to install the package for all users)

Usage

ClientApiClientFactory manages creation of clients on the running service. We currently only support connecting to a service running on a localhost (eg. 'http://localhost:5000/').

To start the service, manually navigate to the "C:\Program Files\IDEA StatiCa\StatiCa 24.0\net6.0-windows" folder. Using CLI:

IdeaStatiCa.ConnectionRestApi.exe -port:5000
// Connect any new service to latest version of IDEA StatiCa.
client_factory = ConnectionApiClientFactory('http://localhost:5000/')
conClient = client_factory.create_connection_api_client();

Getting Started

Please follow the installation procedure and then run the following:

Documentation for API Endpoints

The ConnectionApiClient wraps all API endpoing controllers into object based or action baseds API endpoints.

Methods marked with an ^ denote that they have an additional extension in the Client.

CalculationApi

Method Description
calculate Calculate RCS project
get_results Get calculated results

CrossSectionApi

Method Description
import_reinforced_cross_section Import reinforced cross-section
reinforced_cross_sections Get reinforced cross sections

DesignMemberApi

Method Description
members Get members

InternalForcesApi

Method Description
get_section_loading Get section loading
set_section_loading Set section loading

ProjectApi

Method Description
close_project
download_project Download the actual rcs project from the service. It includes all changes which were made by previous API calls.
get_active_project
get_code_settings
import_iom
import_iom_file
open
open_project Open Rcs project from rcsFile
update_code_settings

SectionApi

Method Description
sections Get sections
update_section Update a section in the RCS project

Documentation for Models

Notes

This Python package is automatically generated by the OpenAPI Generator project: